I updated Quicken because I was forced to, and we all loathe Quicken in one fashion or another, generally those of us in UI seriously need a job there. It would take months if not years to re-do this thing right, but then again what is their incentive? It’s a cash cow, no updates / improvements / bug-fixes, but everyone has to keep pony’ing up every 3rd year.

So I came across this one, in using it. OMG, what a retarded warning, so much so it will just make an JR / BASIC / ENTRY-LEVEL / etc, programmer laugh, and the rest of us to just cringe.